Overview:
Some Configurable Search Layout Columns are not in the configured order in CRM.
Root Cause:
In some cases, Veeva hard-codes object attributes that are presented as part of the Lookup Dialogs.
Hard-coded columns appear prior to any additional columns. The order is not configurable.
Solution:
This is the expected behavior.
Related Documentation:
CRM Online Help: Configurable Lookup Filters and Layouts