Overview:
When an Approved Email is forwarded to a group of email recipients, and one of these recipients unsubscribes from the email, the Channel_Value_vod field on the resulting Multichannel_Consent_vod record is populated with the email address of the original email recipient, not the person it was forwarded to who then clicked the unsubscribe link.
Root Cause:
This is expected behavior. The unsubscribe link on a Sent Email is created when the email is processed by the Multichannel (MC) Engine, at the time the email is sent. This link is a static link that represents a specific Sent_Email_vod record, for a specific Account and Channel Value.
The link is not updated if the email is forwarded, and will continue to represent an opt-out link for the original recipient. This is true for any email, and is not solely an Approved Email limitation.
Related Documentation:
CRM Online Help: Components of Consent Capture