Overview:
A user receives an Error when accessing a Dashboard:
Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.
Root Cause:
When a Platform licensed user attempts to access a dashboard, they may encounter an insufficient privileges error.
For a Non - Dynamic Dashboard, this error occurs because the running user for the dashboard being accessed does not share the same license type of the individual trying to access it.
For example, if a Platform user attempts to access a dashboard with a running user of a full Salesforce.com license type, they will encounter this error.
For a Dynamic Dashboard, this error occurs because the original running user of the dashboard is most likely a full Salesforce.com license type.
Solution:
To resolve:
- Click Edit on the dashboard.
- At the top right, next to the View dashboard as field, click on the drop-down arrow and choose Run as specified user and then click OK.
- Enter a Salesforce Platform license user in the View dashboard as field.
- Switch the dashboard back to Run as logged-in user.
- Save the dashboard.
Related Documentation:
SFDC Knowledge Article: Knowledge Article: 000205376