Overview:
Salesforce Attachment records are not being synced to Veeva CRM for iPad. The Notes and Attachments related list has been added to the page layout. An Attachment has been uploaded and a VMobile Object Configuration (VMOC) exists for the Attachment object.
The user is able to download and view the Attachment Online without any issues.
Root Cause:
The file is uploaded as a ContentDocument (File object) instead of an Attachment. This is caused by the Files uploaded to the Attachments related list on records are uploaded as Salesforce Files, not as attachments Salesforce setting.
Solution:
- Navigate to: Setup --> Customize --> Salesforce Files --> Settings --> General Settings.
- Disable the Files uploaded to the Attachments related list on records are uploaded as Salesforce Files, not as attachments setting.
- Re-upload the Attachment record.
- Sync the user.
Related Documentation:
- CRM Help Documentation: N/A
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