Overview:
After iPad sync, the child records containing attached photos of an Inventory Monitoring record are unavailable Offline. The photos are only shown in the Online child records.
Root Cause:
When Photo Tagging is enabled in Inventory Monitoring (by placing the zvod_Photo_Tag_vod marker field on the page layout), only the parent record is visible on iPad without the photo attachment. With each photo, a child record is created, but it is only visible online in the Inventory Monitoring related list on the respective Account page layout.
Solution:
This is expected. The photos on each inventory monitoring record are available only On Demand, as they are deleted from the device as soon as a successful sync is made. The photos can be retrieved the following way:
- Tap on Edit.
- A download icon appears in the layout section where the zvod_Photo_tag marker field is placed.
- Tap on the download icon.
- The image is downloaded on the iPad.
However, if the zvod_Photo_Tag_vod marker field is removed from the Inventory Monitoring page layout, Photo Tagging is disabled. Photo attachments can be uploaded to the Inventory Monitoring record itself and no child records are created. The attachments are available both Online and Offline in the Attachments related list after sync.
Related Documentation:
CRM Help Documentation: Using Photos to Monitor Inventory