Overview:
When the end-user performs sync on iRep, the following error appears in the Error tab and stops the calls from uploading:
Error: duplicate value found: {Field Name} duplicates value on record with id: XXXXXXXXXXXXXXX.
Root Cause:
There is a custom unique external Id field in Call.
By default, when creating a Call, all the custom fields are copied from the parent to the child Calls. Since it is a unique external Id, the copied value causes the duplicate error when iRep sync tries to upload the Call to Online.
Solution:
To correct the error, do the following:
- Take away Field Level Security (FLS) to the field from the end-user profile.
- Populate its value using a trigger.
- Put this field to the Attendee Specific Fields (--atf) section.
Related Documentation:
CRM Help Documentation: Attendee Target Filter
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.