Overview:
Attach File button does not appear on the Notes & Attachments related list for Inventory Monitoring record in CRM Online.

Root Cause:
Camera_Roll_vod is the Veeva setting that regulates the Inventory Monitoring Attachments. The values are:
- 0 - Camera Roll is on
- 1 - Camera Roll is off
Solution:
Set the Camera Roll Veeva Setting to 0.
Related Documentation:
CRM Help Documentation: