Overview:
CRM Workflow Rule using Record Type criteria is not Firing in CRM.
Root Cause:
Workflow Rules using Record Type criteria must use the untranslated Master Record Type Label.
The Lookup Search under Rule Criteria displays Translated Record Type Values and adds them to the Value field when selected. Rules created by adding Record Type values that are translated do not function.
Many standard Veeva Record Types include _vod in the Master Record Type Label and are translated to the user-facing value using Translation Workbench.
Solution:
Manually enter the untranslated Master Record Type Label in the Value for the Record Type criteria.
Related Documentation:
Salesforce Help Documentation: Workflow Considerations
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