Overview:
A Market Sales Analysis report shows an error when the report is correctly configured: There is no data for the selected filters.
Root Cause:
When the Market Sales Analysis report is configured for previously processed data files, the tables required for Market Sales Analysis report may not be correctly generated in the Analytics database.
Solution:
Analytics data file needs to be reprocessed by clicking the Reprocess link on the Analytics Admin page for the file. Or, reload the file to the Analytics FTP and process it again.
Related Documentation:
CRM Help Documentation: Viewing Reports in the Analytics Tab