Overview:
All essential configurations have been met but the consent records are not created after submitting in CRM Online. There are no errors displayed.
Root Cause:
Check whether the insufficient access rights on cross-reference id error occurs in the Network section of the browser developer tool while submitting the consent record. If this is the scenario, the Account Access of the user's Territory only has view access. It should have view and edit access.

Solution:
Grant view and edit to Account Access of the user's Territory.
Related Documentation:
N/A
Thank you