Overview:
The following error is listed in the Activity Log and the Options Media section in Veeva CRM for offline devices:
Unzip failed for file /var/mobile/Containers/Data/Application...SLIDENAME.zip.
Root Cause:
In an Org where CLM content is hosted on the Veeva CDN through the Vault integration during sync, the offline device looks to the CDN Path field for the location of the zip file. If the CDN Path field is not available, it defaults to downloading the content from the Veeva Content Server. When it tries to unzip the file that does not exist, the error message is displayed.
Solution:
The end-user needs Read Field Level Security (FLS) to the following fields on the Key Message object:
- CDN Path - Key_Message_vod.CDN_Path_vod__c
- Vault GUID - Key_Message_vod.Vault_GUID_vod__c
If the key message is packaged incorrectly, this error appears.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for CLM