Overview:
Users are unable to see a Contract in the Contract Lookup field when creating a new contract Offline. The record displays correctly Online in the lookup when creating them Online.
Root Cause:
For this functionality to work Offline, the Record Type names for the Contract and the Contract Partner need to match.
Solution:
Be sure to use matching Record Type names when using custom Record Types for the Contract_vod__c and Contract_Partner_vod__c objects.
Related Documentation:
CRM Help Documentation: Architecture of a Contract
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