Overview:
The user is not able to see the proper document state change user action in Vault, even though the user has the proper lifecycle state permissions in order to perform this action.
Root Cause:
A required document field is configured as Hidden for all users except for users that have a Vault Owner security profile.
Solution:
Edit the configuration of the affected document field so that the affected user is able to read or edit the affected document field. This can be done by assigning Read-Only or Editable permissions to the affected user in the document field configuration.
Related Documentation:
- Vault Field Documentation: Configuring Field-Level Security
- Vault Admin Documentation: Managing Document Fields
Thank you