Overview:
The More Actions button is not displaying the Send Email option during a Business initiated group Call, but the option appears during individual Calls and in Offline Calls.
Root Cause:
To send emails from Call reports, the More Actions functionality needs to be configured.
In order for an option to display in the More Actions picklist menu, the user must also have Create access for the underlying object as well as access to the object as a related list in the Account page layout for the primary account of the call.
For Online use, the Sent Email related list is on the Account page layout. The user needs Create access on the Sent_Email_vod object.
For Offline use, More Actions are enabled based only on object permissions.
Solution:
- Add the Sent Email related list to all Account page layouts that require approved email functionality.
- Verify that the user has Create access on the Sent_Email_vod object.
- Configure the More Actions button:
- Add the zvod_More_Actions_vod field to the zvod_buttons section of the desired Call page layout.
- Provide Field Level Security (FLS) Edit privileges to the zvod_More_Actions_vod field for the desired profiles and Record Types.
Related Documentation:
CRM Online Help: Using the More Actions Button