Overview:
The Key message does not update when uploading using FTP. The media file and control files are removed as expected but the Key message stays the same.
Root Cause:
When using Vault integration for CLM, the unique attribute for some fields needs to be removed.
Solution:
From the Help Documentation, In order for the integration to update CLM records in CRM from Veeva Vault, remove the unique attribute for the following fields:
- Key_Message_vod__c - Media_File_Name_vod__c
- CLM_Presentation_vod__c - Presentation_Id_vod__c
In order to avoid duplicates from being written, this requires Modify All Data profile level Administrative permission for the user who is trying to upload media using FTP.
Review the org configuration:
- If Vault integration is not being used, then add the unique attribute to those fields.
- If Vault integration is used, an admin user with a Salesforce user license, with Modify All Data administrative permission needs to upload content using FTP.
Related Documentation:
CRM Help Documentation: Uploading Content via CLM Vault Integration
Thank you