Overview:
A user receives an error: You do not have sufficient privileges to Edit this record - when trying to edit the Ratings and Evaluations in a CRM Org?
Root Cause:
The cause of this error is that the affected user's assigned Territory has Account Access set only to Users in this territory can view accounts assigned to this territory.
Solution:
To be able to modify Ratings and Evaluations, this needs to be set to Users in this territory can view and edit accounts assigned to this territory.
Related Documentation:
N/A