Overview:
A Manager in CRM is unable to access a team's Time off Territory records using My Schedule in iRep. This same manager can correctly view the Time off Territory records using My Schedule Online.
Root Cause:
The manager does not have Offline visibility to the records that normally display in My Schedule when viewing a team member's schedule. Offline visibility to records is controlled by the WHERE Clause on the Vmobile Object Configuration (VMOC) record for the Time_off_Territory_vod object. By design, only the parent territory can see the direct child territory and not those below the child in the hierarchy.
Solution:
- Log into the Org as a System Administrator.
- Navigate to All Tabs (+).
- Drill into the Vmobile Object Configuration tab.
- Find the VMOC record for the Time_Off_Territory_vod object.
- Take Note of the WHERE clause.
- For a Manager, the WHERE clause needs to either be blank or setup to download team member records.
Examples:
The following WHERE clause does not work for managers if they are in a territory more than two levels higher than team members:
WHERE @@VOD_USERS_IN_MY_TERRITORY:OwnerId@@
Related Documentation:
N/A
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