Overview:
CRM Approved Emails are not sending with a custom domain. All Sent Emails contain the following error: Status Details - Failed to send email request to the mail provider due to incorrect email domain value.
Root Cause:
The Email Domain configured in the APPROVED_EMAIL_DOMAIN_VOD is not registered with Veeva's Sending Domain Solution.
Solution:
Open a ticket with Veeva Support to request Approved Email Domain setup assistance.
Related Documentation:
CRM Help Documentation: Creating a Sending Domain