Overview:
When a coach is trying to send the Coaching Report to the Rep an error occurs: You do not have permission to send the Coaching report to the employee.
Root Cause:
Be sure the Coach has read Field Level Security (FLS) permission on the following fields:
- Survey_vod.Start_Date_vod
- Survey_vod.End_Date_vod
- Survey_Target_vod.Employee_vod
- Survey_Target_vod.Coach_vod
- Survey_Target_vod.Report_Status_vod
The Coach should have edit FLS permission on the Survey_Target_vod.Sent_To_Employee_Datetime_vod field.
Solution:
Full Access should be granted at the Profile Level or through a Permission Set.
Related Documentation:
CRM Help Documentation: Advanced Coaching Report