Overview:
When attempting to send an Approved Email online, the following error message appears: There are no Consent_Type_vod records applicable for this Account. Please review your Consent Capture setup.
However, the org has a valid Approved Email Consent_Type_vod record for the given Country and Account.
Root Cause:
When an org has multiple Consent Header records for the same Country but with different languages configured, one of the Consent Header records contains an invalid Consent Type record.
Consent Headers for the same Country must all have the same number of Consent Type records for the same channels.
Solution:
Confirm that each Consent Header record for the given Country contains valid Consent Type records. For Approved Email, each Consent Header should have a Consent Type record with the Approved Email record type.
For example:
- Consent Header 1 - US has a Consent Type record with the Approved Email record type.
- Consent Header 2 - US has a Consent Type record with a CLM record type.
Consent Header 2 - US should be configured to have a Consent Type record with the Approved Email record type; not the CLM record type.
Related Documentation:
CRM Help Documentation: Capture Consent Overview