Overview:
When clicking on the Assign Call Objective to Tactic button on the Account Tactic page in the Call Objectives Related List, no records appear in the lookup window even though there are related Call Objective records.
Root Cause:
There are insufficient permissions for the user to relevant fields on the Account_Tactic_vod object.
Solution:
Provide Field Level Security (FLS) permission to the following fields for the user:
- Call_Objective_vod.Account_Tactic_vod
- Call_Objective_vod.Parent_Objective_vod
- Call_Objective_vod.Recurring_vod
Related Documentation:
CRM Help Documentation: Account Tactics