Overview:
Multiple versions of the same document or past document versions are listed in the Vault search results and/or Reporting.
Root Cause:
The affected user is assigned to multiple lifecycle roles in the Sharing Settings on that document. And at least one of these lifecycle roles has View Document permissions in a previous version of the document but not the current version.
Solution:
Each version of a Vault document stores the groups and users for which it is the latest version. Vault uses that data to show each user the latest versions they have access to when searching for documents.
However, if a user belongs to multiple lifecycle roles in the Sharing Settings, it is possible that the latest version of a document that a user can access differs between the roles they belong to. By belonging to multiple roles, the user effectively has two versions of a document which are the latest versions.
The solution is to grant View Document permissions to the affected lifecycle role in the current version of the affected document.
Related Documentation:
Vault Search Documentation: Matching Across Document Versions