Overview:
A Data Change Request (DCR) is sent to Veeva Network to replace the current Parent Account with a new one in an existing Child Account record. This change is processed in Veeva Network successfully, but the DCR returns an error message: One or more DCR objects failed import: Failed to upsert Child_Account_vod__c.
Root Cause:
Replacing a Parent Account is not possible due to a missing configuration in the Parent_Account_vod__c field in the Child Account object.
Solution:
Before the CRM V21 release, the Child Account object is delivered with Parent_Account_vod__c as a Master-Detail type field. CRM orgs created after this release have a field type as Lookup. In orgs where the field type is still Master-Detail, there are two ways to resolve this behavior:
- Check the Reparentable Master Detail setting:
- Enabling (checking) this setting has the following implications:
- The subscription import of Parent Health Care Organizations (HCOs) is processed serially (rather than in parallel) to try to minimize the locking problem when two children try to import Child Accounts pointing to the same parent. This can slow down the process significantly.
- The Account Hierarchy view is only able to show HCOs in a user's territory. End-users are unable to request the realignment of a parent from that feature.
- Enabling (checking) this setting has the following implications:
- Change the field type from Master-Detail to Lookup. This allows users in the Account Hierarchy feature to see parent Accounts that are not in their territory, and optionally re-align them.
Related Documentation:
CRM Help Documentation: Account Hierarchies