Overview:
A Survey Designer user publishes a Survey through Multichannel engine (MC Engine). The Survey is in published status but the notification email is not sent to the user.
Root Cause:
This is expected behavior. If a Survey is published through MC Engine, notification email is not generated and sent to the user.
Solution:
This is working as designed. A notification email is only sent to the user if the Survey is published through the VEEVA_BATCH_SURVEY_PUBLISH Apex Class.
Related Documentation:
CRM Help Documentation: Publishing a Survey
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.