Overview:
An object is not appearing in the Enabled Objects section from the Validation Rule Admin tab after adding a new validation rule and Refreshing Validation Rule Data.
Root Cause:
A VMobile Object Configurations (VMOC) with devices set as either iPad or WinModern is required to be picked up in the Validation Rule Admin.
Solution:
Be sure an active VMOC exists for the object and it is has Device set to either iPad or WinModern.
Related Documentation:
CRM Help Documentation: Offline Validation Rules