Overview:
When syncing Calls after an Account merge, an error occurs: entity is deleted.
Root Cause:
This is occurring because the Entity_Reference_Id_vod on the Call refers to the ID of the Account that lost the Merge.
Additionally, the user does not have Read access to the Account_Merge_History_vod Object and its fields.
Solution:
The user needs Read access to the Account_Merge_History_vod Object and an active VMobile Object Configuration (VMOC) for this object in order for syncs with merges to work properly.
Related Documentation:
CRM Help Documentation: Merging Duplicate Account or Contact-Related Records