Overview:
When a user creates a duplicate account (both Person Account and Business Account) with the exact same details, no duplicate record alert is prompted. The user language is not set to English.
Root Cause:
This is expected. The Soundex comparisons, which is used by the Account Wizard, only work for the English language.
Solution:
By design, the New Account Wizard only searches for duplicates if the user language is set to English.
Related Documentation:
CRM Help Documentation: Duplicate Record Checking in Account Wizards
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