Overview:
A user creates calls and Detail Products assigned to Detail Groups. Products and Detail Groups are set correctly for the user through My Setup. The user experiences the following behavior:
Scenario A: User creates a call, Detail Products assigned to Detail Groups, and submits the call. The Detail Group is stamped correctly on the Call record.
Scenario B: User creates a call, Detail Products assigned to Detail Groups, and saves the call. The user returns to the saved call record and edits it. Products are reset to the Common Detail Group.
- The user does not select the Detail Group again and submits the call. The Detail Group name is not stamped, Products are detailed in the Common Detail Group.
- The user selects the Detail Group again and submits the call. The Detail Group is stamped correctly on the Call record.
Root Cause:
This is expected behavior if the user does not have Field-Level Security (FLS) access to the Detail_Group_vod__c field on object Call2_Detail_vod__c. To stamp the Detail Groups on call records correctly, FLS access needs to be granted.
Solution:
- Navigate to the User Detail page of the user.
- Click on the Profile link in the Profile field.
- In the Field-Level Security section, navigate to the Call Detail object.
- Grant access to field Detail_Group_vod__c.
Related Documentation:
CRM Help Documentation:
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