Overview:
When using the ObjectAPIName.FieldAPIName with User Objects, the tokens do not display.
Example: {{user.Email}}
Root Cause:
The token Syntax for Object names is case sensitive and do not properly insert the Object.Field if the case is not followed.
Solution:
The token needs to be updated to use a capital letter U. Example: {{User.Email}}
Related Documentation:
CRM Help Documentation: Approved Email Configuration Tokens