Overview:
Upon finishing the creation of a new Align sandbox using Sandbox Vaults, the following error displays when logging into it through https://login.veevavault.com/:
Sorry, but the requested page was not found.
Please double-check the URL and try again. If the issue persists, please contact Veeva Support and copy the URL and datetime below into the support ticket.
Request URL: xxxxxxxx
Current Datetime (UTC): xxxx-xx-xxTxx:xx:xx.xxxZ
The error is not present in Business Admin, only in Vault view. The error may persist after waiting one day, in the event the Align Admin user has not been set up.
Root Cause:
Background:
This error implies that the Align sandbox is not upgraded to the latest Align version. The Align version is not upgraded until the instance is not in the Align managed list. In turn, the instance is not managed as long as the Align Admin user is not set up appropriately.
Scenario:
The error occurs as the result of these events in this sequential order:
- A new Align sandbox gets created, however, the Align Admin user is not set up or it is, but inappropriately. At this point, the instance is still available for use in Vault View.
- A newer Align release gets deployed
- As the instance is not managed, consequently it cannot be upgraded, and the error displays.
Solutions:
Solution #1
After the creation process finishes in the Sandbox Vaults tab of the parent org, the Align sandbox must be added to the Align Managed List. This is carried out by a script running in the backend. However, in order for the script to pick up the Align sandbox, its Align Admin user must be created and configured based on the following properties in Users & Groups:
- Status – Active
- User Name – align.admin@yourdomain.com
- Email – align_admin@veeva.com
- License Type – Full User
- Security Profile – Vault Owner
- Domain Admin – Optional
The Align Admin user has a similar purpose compared to the Veeva Admin (Vadmin) user in CRM. Once the Align Admin user has been created, the script will make the instance managed and upgrade it to the latest Align version. Note that this is not the Vault version. The instance should be ready for use once the script picks up the affected Align sandbox.
Solution #2 (Temporary)
In the event an immediate solution is necessary, refresh the Align Sandbox from the parent org it was created. Refreshing the affected instance ensures that the latest versions match, proposing the parent org is on the latest version and managed. This solution is temporary, and also does not get the affected sandbox into the managed list. It is recommended to proceed with Solution #1 as soon as possible.
- The script runs on weekdays only, at 11:30 AM PST (8:30 PM CET).
- All customer Align sandboxes are required to be made managed eventually.
Related Documentation:
Align Help Documentation: