Overview:
When a Call is submitted by Data load, it is possible for a Sample Limit to get a negative value in CRM.
Root Cause:
The Sample Limit is only enforced Offline and on the Online VisualForce page. The Sample Limit can get a negative value.
Solution:
This is working as designed. When data loading a Call with Samples, the API recalculates the Sample Limits to reflect the truth of what is loaded.
Due to the nature of a data load (the data does not reflect what a user is doing at the present moment on the field, but rather what has happened in the past), it is possible to see a negative value for the Sample Limit.
Related Documentation:
CRM Help Documentation: Creating Sample and Product Limits