Overview:
The same Engage Meeting is related to two parent calls in CRM.
For the two different Engage Meeting calls, the Remote Meeting and Participant URL are the same. Both calls have Call Type as Detail Only and they are parent calls.
Root Cause:
This is because that the same call is submitted twice.
Example:
If the user submits the call online and then submits it again from CRM iPad, the original call ID is stamped in the Error_Reference_Call_vod__c field of the last call.
Solution:
Currently, users are advised to not submit a call repeatedly to avoid this issue.
Related Documentation:
CRM Help Documentation: Default Functionality for Engage Meeting