Overview:
When Editing TSF fields from the Territory Fields section of an Account in CRM online, the My Preferred Address Picklist (Address_vod field on the TSF_vod object) is expected to populate with all Addresses available to the user. Additionally, My Preferred Address is not automatically updating when a Call is recorded even if the value in Address_vod is null.
Root Cause:
This issue can occur when the user is missing FLS to a field on the Address_vod object required for Account Management.
Solution:
Ensure that users have the specified fields described in Configuring Accounts.
Related Documentation:
CRM Help Documentation: Configuring Accounts