Overview:
While Creating/Editing an Event Team Member, the Team Member's name is automatically changed to the Salesforce Record ID.
Root Cause:
The user has FLS on the Team Member Type field and it defaults to User for example. This causes the Name Lookup to search for an existing User as per entered name in the org and as it does not find anything, the system will automatically populate the Name with the Salesforce Record ID instead.
Solution:
- If the affected user has Edit FLS on the Team Member Type field on the EM_Event_Team_Member_vod object, a valid value needs to be inserted (such as a username) depending on the selected Type.
- If the user has no Edit FLS on the Team Member Type field and its value is also not mandatory to be populated, the Team Member can be saved with a custom Name value and without a Team Member Type.
Related Documentation:
CRM Help Documentation: Event Team Members