Overview:
The HTML report is not visible Online in Veeva CRM Lightning while the report is placed on either the Lightning Home Page or Lightning Record Page and all the configuration is done.
Root Cause:
The org’s Salesforce domain configuration is not correct.
The following errors may indicate this from the Browser's Console:
Solution:
Check the CSP Trusted Sites configuration under Setup > Security.
According to the CRM Help Documentation, the domain from the Salesforce Domain has to be added. It can be found in Setup > My Domain settings instead of directly copying the URL from the browser.
Related Documentation:
CRM Help Documentation: Viewing MyInsights Content in Lightning