Overview:
A customer creates new Accounts through Data Change Requests.
Veeva Setting ACCT_PREVIEW_DURING_CREATION_vod and Network Setting ACCT_PREVIEW_DURING_CREATION_vod are enabled: customer can preview and modify Account information after creating the Account record in the Account Wizard and before submitting the Data Change Request record.
Customer has edit Field-Level Security (FLS) to fields Name, FirstName and LastName on the Account object.
There are DCR Field Type records created for Account fields FirstName and LastName.
Instead of fields FirstName and LastName standard Salesforce field Name is displayed on the Account Preview Page if a Person Account is created and it cannot be populated. The following error occurs:
error saving value: Unable to create/update fields: Name. Please check the security settings of this field and verify that it is read/write for your profile or permission set.
Fields FirstName and LastName. can be populated on new Account records if Account Preview Page is not enabled.
Root Cause:
There are two fields with the same label - 'Account Name' - on the Account object.
Solution:
Please make sure that only standard Salesforce field 'Name' has the label 'Account Name'.
Related Documentation:
CRM Knowledge Article: Previewing an Account During Creation