Overview:
The user is unable to switch from Production to Sandbox Environment even though OAuth 2.0 MDM Support is configured. The user receives the following error when attempting to switch on their iPad; "authorize File – 11 Bytes Open in…"
Root Cause:
In most cases, the Client id and Client Secret in the Veeva_CRM connected app online do not match the values in the OAuth2 configuration file.
Solution:
The customer's admin should copy and paste the correct values from the connected app online into their OAuth2 configuration XML file.
In the Lightning Experience Go to Setup --> Search App --> Go To App Manager --> Locate Your connected app and Click on the "down" arrow on the right side of the listed app --> Select View.
The Consumer Key and Consumer Secret value will be displayed.
Related Documentation:
CRM Help Documentation: Deploying Veeva CRM on iOS with OAuth 2.0 Support (MDM/MAM)
SFDC Article: How to get client_id, client secret, and security token?