Overview:
The user uses Save for Later on CRM iPad, but the product is not stamped on Call Key Message after associating Accounts with tracked CLM Activity. However, if the user records a call and then presents the presentation, the product is stamped normally.
Root Cause:
One reason is that the user does not have Edit Field Level Security (FLS) to the product field on the Multichannel Activity Line.
Solution:
Grant the user Edit FLS to the product field on the Multichannel Activity Line.
Please refer to Field-Level Security if needed.
Related Documentation:
CRM Help Documentation: Associating Accounts with Tracked CLM Activity