Overview:
An Approved Email has been sent successfully within Events Management module but no Email Activity record gets created when the recipient clicks the RSVP link. Opened and Delivered activities are present in the Sent Email record.
Root Cause:
The used template contains the insertEngageAndZoomJoinURL token which is not supporting click tracking.
Solution:
Remove the insertEngageAndZoomJoinURL token from the template in order to create Email Activity with Clicked event.
Related Documentation:
CRM Online Help: