Overview:
Users can submit the call with a location Value of None even though the Disable Call Location None Veeva Setting is Checked.
As per our documentation, the Disable Call Location None Veeva setting, when checked, should enforce the selection of a location value by hiding the None option in the location picklist.
Root Cause:
In most cases, the value of the Do_Not_Call_vod__c field on the Account records is set to N instead of No_vod.
Solution:
The customer should set the Do_Not_Call_vod__c value on the Account record to No_vod.
Related Documentation:
CRM Help Documentation: Selecting the Call Location