Overview:
A user creates a new Address for a new Account on iPad. The record type of the Account is referenced in Veeva Message CRM_MANAGED_ACCOUNT_TYPES. After the user syncs, duplicate Addresses are created.
Root Cause:
User does not have FLS (Field-Level Security) to field Copy_Address_vod__c on object Child_Account_vod__c.
Solution:
Grant FLS (Field-Level Security) to field Copy_Address_vod__c on object Child_Account_vod__c for the user.
Access the user's Profile > go to section Field-Level Security > click on View next to Child Account > click on Edit > grant access to field Copy_Address_vod__c.