Problem:
Validation rule containing the Sample_Card_Reason_vod field is not working as it should, even though the field value criteria seems okay.
Root Cause:
The Call has a Child Call / is a Child Call.
The validation rule is running against both the Parent Call and the Child Call, however, the Sample_Card_Reason_vod field is not stamped on Child Calls. Even though the value is visible on the UI for the Child Call, when looking at the data for the call, this field is blank.
Solution:
This behavior is expected because Sample_Card_Reason_vod field is the part of fields used as the replacement of the Signature of the recipient of samples.
It means only one call can have it (the same as Signature will be saved in only one call), which is generally the Parent Call.
The validation rule should be modified in a way to only check Sample_Card_Reason_vod field for Parent Calls only, or the calls with Is_Sampled_Call_vod__c=true, for example.
Related Documentation:
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