Problem:
During manually unlocking a quiz a Server having problems banner message appears and the quiz can not be unlocked.
Root Cause:
The reason that the user can't unlock the quiz is that during the execution of the unlock quiz action, the user selects a new due date. Choosing the new due date means Vault will try to set the new Due Date on the Training Assignment and also will try to update the due date on the attached workflow. However, the Training Assignment has an active workflow that has the "Update active task due date when date field is updated" option checked in the Task step. This setting/configuration is incompatible with the automation within the Training application which automatically updates the workflow's due date.
Solution:
Disable the option and any new workflows beyond that change will not run into this issue.
Current TA's quiz can be unlocked automatically once the lock period reaches.
Related Documentation:
Vault Help: Calculated Task Due Dates