Overview:
Clicking into Available Tasks does not display documents even though the Vault home Page shows there are Available Tasks.
Root Cause:
The viewer role does not have View privileges to the document in the current state.
Solution:
For any User tasks, the user is assigned the Viewer role prior to accepting the task. If this role does not have View access to the document, the document is not displayed in the Available Tasks section.
To assign a Viewer group to the correct access, do the following:
- Navigate to: Admin --> Configuration --> Lifecycles & Workflows --> [Lifecycle] --> States --> [State] --> Security Settings.
- Assign View Document permission to the Viewer role.

Related Documentation:
Vault Help Documentation:
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.
Thank you