Overview:
A User has multiple Views on My Accounts. The User is unable to switch between different views. In addition, a selected view is switched back to the original view.
Root Cause:
Check Permissions on the Preferences object.
Solution:
The user needs Read, Edit, and Create access to the Preferences object. When views are changed in My Accounts, the Preferences object is updated with the last view used. So, the user must have Read, Edit, and Create access to this object.
Related Documentation:
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.