Overview:
How to configure a non-Administrator user to be able to create and edit My Accounts Views?
Root Cause:
Object Permissions and System Permissions are required.
Solution:
-
When the user is not the owner of the View, the profile needs View Setup and Configuration Permission.
-
If View Setup and Configuration is not enabled and the user clicks on the Create New View link in My Accounts, the user does not see Bullet 1 in Step 4: Visibility (below). The user is not able to share the view with other users. The user can only create Views.
-
The Manage Public List Views permission relates to standard Salesforce tabs and does not apply to My Accounts.
-
Profile_vod__c field on the View_vod__c object:
-
If Not Visible: By removing Field Level Security (FLS) permission for a profile, the user in this profile cannot edit.
-
If Read Only: User cannot create Views.
Related Documentation:
N/A
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.
Thank you