Overview:
The YTD Call field on the Territory Specific Field (TSF) object does not automatically reset at the beginning of a new year in CRM.
Root Cause:
This is working as designed. The TSF object is maintained by triggers. Therefore, the values do not automatically reset each year.
Solution:
Several options are available for zeroing out the YTD Call field:
- Use Dataloader to reset the field to 0.
- Create an Apex job to reset the field at the beginning of each year.
- The YTD Call field automatically updates for Accounts when a Call from the new year is added.
Related Documentation:
CRM Help Documentation: Working with Territory Fields