Overview:
Error: Document Not Found - Occurs after moving a Vault document to a new state and attempting to view the document.
Root Cause:
The Role, to which the user is assigned, does not have View Document permission in the new lifecycle state to which the document is moved.
Solution:
- Navigate to: Admin --> Configuration --> Document Lifecycle --> [Lifecycle] --> States --> [State] --> Security.
- Grant View Document permission to the Role in which the user is assigned.
Related Documentation:
Vault Help Documentation: Defining Document Role Permissions (Security Settings)