Overview:
Error: Username exists - when trying to create a new Vault user.
Root Cause:
The username is in use within the Domain.
Solution:
A Vault user is created at the Domain level. The user is assigned access to the Vaults on the Domain. A Domain Admin can view all users on a Domain by navigating to: Admin --> Users & Groups --> Domain Users page. Use the following steps:
- Find the user Account in question.
- Click on the Vaults tab to set the Vault to which the user has access.
- Set the user as Active in specific Vaults, as well as at the Domain level.
Users not active at the Domain level are not able to log into any Vaults on that Domain.
Related Documentation:
- Vault Help Documentation: Vault Help