Overview:
The Workflow History Report was reporting the incorrect version for tasks completed.
Root Cause:
The Workflow History Report captures the version that the workflow is active on, not the one it's completed on.
Solution:
The document version column in the Workflow History Report records the document version in which the workflow was active on, not the document version in which a workflow task is completed. In order to see the document version in which a workflow task was completed, look at the Doc Info Page in the Workflow History panel, so long as the relevant tasks have that feature enabled in the workflow task configuration.
Related Documentation:
N/A
Thank you